Delayed event delivery in Routing

Incident Report for Permutive

Resolved

The issue causing delayed event delivery in Routing has been resolved. All events have been delivered and delivery times have returned to normal. No events were lost during the incident.
We apologise for the disruption.
Posted Feb 18, 2026 - 17:23 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 18, 2026 - 16:55 UTC

Identified

We have identified an issue affecting our Routing product where some events are experiencing delayed delivery to customer data warehouses. While the majority of events are being delivered promptly, a subset may be delayed by up to 6 hours.
The cause has been identified and a fix is currently being applied. We will provide a further update once delivery times have returned to normal.
We apologise for any inconvenience.
Posted Feb 18, 2026 - 11:31 UTC
This incident affected: Routing.