Insights Platform Instability

Incident Report for Permutive

Resolved

This incident has been resolved and all impacted services are fully operational:

Planning
Cohort Sizes
AI Recommendations (Optimisation)
Dashboard
Posted Mar 03, 2026 - 19:01 UTC

Monitoring

We are continuing to work on restoring the affected Insights services. Our team has identified the issue and has implemented changes to resolve it.

All impacted services are currently recovering and returning to fully operational:

- Dashboard
- Planning
- AI Recommendations in Optimization
- Live Audience Sizes
- Cohort Export

We will continue to monitor the situation and provide a further update once we have confirmed the issue has been resolved.
Posted Mar 03, 2026 - 13:52 UTC

Identified

We are currently experiencing issues with our Insights platform, which is impacting the availability of the following areas:

Planning
Cohort Sizes
AI Recommendations (Optimisation)
Dashboard

Our Engineering team has identified the issue and is actively working to restore full service.
Posted Mar 03, 2026 - 09:47 UTC
This incident affected: Permutive Dashboard and Permutive Analytics.