Data processing delays

Incident Report for Permutive

Resolved

All affected services are now fully operational:

Audience Imports Ingestion
Batch Routing
Insights
Event Metrics in Dashboard
Server-Side Activations

Client-side segmentation and activation operated normally throughout the incident.
No data was lost. We appreciate your patience.
Posted Mar 02, 2026 - 09:00 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 02, 2026 - 08:59 UTC

Update

The following services are now fully operational:

Server-Side Activations
Insights
Audience Imports Ingestion
Batch Routing

We are continuing to work on restoring Event Metrics in Dashboard.
Client-side segmentation and activation continue to operate normally.
We will provide further updates as the situation progresses.
Posted Feb 27, 2026 - 14:28 UTC

Update

Server-Side Activations are now fully operational.
We are continuing to work on restoring the remaining affected services:

Audience Imports Ingestion – Delays in data ingestion
Batch Routing – Delays in batch data delivery (stream routing remains fully operational)
Insights – Delays in data availability
Event Metrics in Dashboard – Delays in metrics updates

Client-side segmentation and activation continue to operate normally.
We will provide further updates as the situation progresses.
Posted Feb 26, 2026 - 08:27 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 26, 2026 - 08:26 UTC

Identified

We are currently experiencing infrastructure issues causing delays to the following services:

- Audience Imports Ingestion – Delays in data ingestion
- Batch Routing – Delays in batch data delivery (stream routing remains fully operational)
- Insights – Delays in data availability
- Event Metrics in Dashboard – Delays in metrics updates
- Server-Side Activations – Delays in segment activation data being sent to partners

Client-side segmentation and activation continue to operate normally.
Our engineering team is investigating and we will provide updates as the situation develops.
Posted Feb 25, 2026 - 15:55 UTC
This incident affected: Permutive Analytics and Routing.