Cross Device/Cross Domain Segmentation Performance Issue
Incident Report for Permutive
Resolved
The latency issue has now been resolved. Thanks for your patience!
Posted Nov 23, 2020 - 19:39 UTC
Update
Over the last few days, we have begun testing a resolution for this disruption. We are pleased to share that testing has gone well and
we expect to deploy a resolution tomorrow, Nov 17.

The latency for traffic remains on the order of minutes during peak periods.
Posted Nov 16, 2020 - 10:47 UTC
Monitoring
Data retrieval delays are now minimal and only present for users during periods of heavy traffic. We are continuing to monitor this and will provide additional updates as we progress.
Posted Nov 13, 2020 - 09:56 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 12, 2020 - 10:58 UTC
Identified
Updates for this issue are actively being applied and data retrieval delays have downgraded from Hours to Minutes.

We will continue to provide updates as we progress to a full resolution.
Posted Nov 12, 2020 - 10:49 UTC
Investigating
We are experiencing an issue for some customers with our cross-device and cross-domain segmentation functionality. This affects a device’s ability to retrieve data from other devices which belong to the same user, from other domains the user has browsed. For some users, there will be significant delays in retrieving this data.

Other segmentation functionality is unaffected, including segmentation based on all historical data, segmentation based on behaviour on the device, AMP segmentation and third-party and second-party data retrieval. Permutive is still able to identify a user correctly.

We have identified an issue with a large queue in our user event syncing functionality and are working on a fix. We will be providing the next progress update within 24 hours
Posted Nov 12, 2020 - 09:55 UTC
This incident affected: Permutive API.