Delayed data in Insights, Live Audience Stats and Plans

Incident Report for Permutive

Monitoring

The underlying issue has been resolved, and data ingestion has resumed.

We are now loading the delayed data from 19 September onwards, and it will progressively appear in Insights, Live Audience Stats and Plans as it is processed.

No data has been lost. We will continue monitoring and post a further update once reporting is fully up to date.
Posted Sep 21, 2026 - 15:18 UTC

Identified

Since 19 September 2026, the data shown in Insights (Audience & Campaign), Live Audience Stats and Plans has been delayed. Reporting in these products currently stops at 19 September and does not yet include the most recent days.

The delay is caused by an issue with a cloud service we rely on to process reporting data. Our engineering team is working with the provider to resolve it.

No data has been lost. Your events continue to be collected as normal, and the missing days will appear automatically once processing resumes. Audience targeting, activation and all other Permutive features are unaffected.

We will post a further update as soon as possible. We apologise for the inconvenience.
Posted Sep 21, 2026 - 09:59 UTC
This incident affects: Permutive Analytics.